No machines found! and no xml file written when executing Get-SqlServerInventoryToClixml.ps1

Mar 6, 2014 at 8:23 PM
Edited Mar 6, 2014 at 8:25 PM
Greetings,
I am logged in as a domain admin for our network. Out of about 10 servers, 7 return successfully, writing the log and xml files. But 3 servers do not complete successfully, failing to write an xml file.

The log files generate, but at the end the message is "No Machines Found!". Is this a common issue, or am I missing something? Thanks!
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2014-03-06 13:05:04.7215 ? Starting Script: C:\data-docs\sql-inven\Get-SqlServerInventoryToClixml.ps1
2014-03-06 13:05:04.7567 ? Beginning SQL Server Inventory
2014-03-06 13:05:04.7625 ? -LoggingPreference: Verbose
2014-03-06 13:05:04.7674 ? -ComputerName: SQLSERVER10
2014-03-06 13:05:04.7713 ? -MaxConcurrencyThrottle: 4
2014-03-06 13:05:04.7752 ? -PrivateOnly: False
2014-03-06 13:05:04.7791 ? -ParentProgressId: -1
2014-03-06 13:05:04.7830 ? -IncludeDatabaseObjectPermissions: False
2014-03-06 13:05:04.7869 ? -IncludeDatabaseObjectInformation: False
2014-03-06 13:05:04.7909 ? -IncludeDatabaseSystemObjects: False
2014-03-06 13:05:04.8045 ? Beginning network scan
2014-03-06 13:05:04.8094 ? -ComputerName: SQLSERVER10
2014-03-06 13:05:04.8133 ? -PrivateOnly: False
2014-03-06 13:05:04.8182 ? -MaxConcurrencyThrottle: 4
2014-03-06 13:05:04.8221 ? -ResolveAliases: True
2014-03-06 13:05:04.8280 ? Resolving IP address for SQLSERVER10
2014-03-06 13:05:05.2625 ? Testing PING connectivity to 1 addresses
2014-03-06 13:05:05.2987 $ Testing PING connectivity to SQLSERVER10.COMPANY.COMPANYDOMAIN.COM (172.19.1.110) [1 of 1]
2014-03-06 13:05:07.5644 $ PING response from SQLSERVER10.COMPANY.COMPANYDOMAIN.COM (172.19.1.110): True
2014-03-06 13:05:07.8261 $ PING connectivity test complete
2014-03-06 13:05:07.8359 ? Testing WMI connectivity to 1 addresses
2014-03-06 13:05:07.8486 $ Testing WMI connectivity to SQLSERVER10.COMPANY.COMPANYDOMAIN.COM (172.19.1.110) [1 of 1]
2014-03-06 13:05:08.1054 $ WMI response from SQLSERVER10.COMPANY.COMPANYDOMAIN.COM (172.19.1.110): True
2014-03-06 13:05:08.5234 $ WMI connectivity test complete
2014-03-06 13:05:08.5410 ? Network scan complete
2014-03-06 13:05:08.5439 ? -IP Addresses Scanned: 1
2014-03-06 13:05:08.5478 ? -PING Replies: 1
2014-03-06 13:05:08.5517 ? -WMI Replies: 1
2014-03-06 13:05:08.5576 ? Beginning SQL Service discovery scan
2014-03-06 13:05:08.6601 ? Scanning SQLSERVER10.COMPANY.COMPANYDOMAIN.COM at IP address 172.19.1.110 for SQL Services [Device 1 of 1]
2014-03-06 13:05:20.4760 ? Found SQL Server named instance SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER102008 at IP address
2014-03-06 13:05:20.4799 ? Found SQL Server named instance SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD at IP address
2014-03-06 13:05:20.4829 ? Found SQL Full-text Filter Daemon Launcher named instance SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD at IP address
2014-03-06 13:05:20.4868 ? Found SQL Server Agent named instance SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER102008 at IP address
2014-03-06 13:05:20.4897 ? Found SQL Server Agent named instance SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD at IP address
2014-03-06 13:05:20.4926 ? Found SQL Server Browser default instance SQLSERVER10.COMPANY.COMPANYDOMAIN.COM at IP address
2014-03-06 13:05:20.7612 ? SQL Server service discovery complete
2014-03-06 13:05:20.7671 ? -SQL Full-text Filter Daemon Launcher Instance Count: 1
2014-03-06 13:05:20.7924 ? -SQL Server Instance Count: 2
2014-03-06 13:05:20.7983 ? -SQL Server Agent Instance Count: 2
2014-03-06 13:05:20.8022 ? -SQL Server Browser Instance Count: 1
2014-03-06 13:05:20.8130 ? Beginning scan of 1 instance(s)
2014-03-06 13:05:20.9380 ? Gathering information from SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD [Instance 1 of 1]
2014-03-06 13:05:21.7905 + Failed to connect to SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD
2014-03-06 13:05:21.7974 + Failed to connect to SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD
2014-03-06 13:05:21.8022 + Failed to connect to SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD
2014-03-06 13:05:21.8071 + [SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD] Error gathering instance information - max error threshold reached (3)
2014-03-06 13:05:21.9683 ! Failed to scan SQLSERVER10.COMPANY.COMPANYDOMAIN.COM\SQLSERVER10STANDARD - 3 errors
2014-03-06 13:05:22.2378 ? Instance scan complete (Success: 0; Failure: 1)
2014-03-06 13:05:22.2661 ? Beginning network scan
2014-03-06 13:05:22.2700 ? -ComputerName: SQLSERVER10.COMPANY.COMPANYDOMAIN.COM
2014-03-06 13:05:22.2730 ? -PrivateOnly: False
2014-03-06 13:05:22.2769 ? -MaxConcurrencyThrottle: 4
2014-03-06 13:05:22.2847 ? -ResolveAliases: False
2014-03-06 13:05:22.2964 ? Resolving IP address for SQLSERVER10.COMPANY.COMPANYDOMAIN.COM
2014-03-06 13:05:22.4224 ? Testing PING connectivity to 1 addresses
2014-03-06 13:05:22.4771 $ Testing PING connectivity to SQLSERVER10.COMPANY.COMPANYDOMAIN.COM (172.19.1.110) [1 of 1]
2014-03-06 13:05:24.7565 $ PING response from SQLSERVER10.COMPANY.COMPANYDOMAIN.COM (172.19.1.110): True
2014-03-06 13:05:25.0280 $ PING connectivity test complete
2014-03-06 13:05:25.0465 ? Testing WMI connectivity to 1 addresses
2014-03-06 13:05:25.1041 $ Testing WMI connectivity to SQLSERVER10.COMPANY.COMPANYDOMAIN.COM (172.19.1.110) [1 of 1]
2014-03-06 13:05:25.3610 $ WMI response from SQLSERVER10.COMPANY.COMPANYDOMAIN.COM (172.19.1.110): True
2014-03-06 13:05:25.6715 $ WMI connectivity test complete
2014-03-06 13:05:25.7633 ? Network scan complete
2014-03-06 13:05:25.7672 ? -IP Addresses Scanned: 1
2014-03-06 13:05:25.7711 ? -PING Replies: 1
2014-03-06 13:05:25.7741 ? -WMI Replies: 1
2014-03-06 13:05:25.7799 ? Beginning machine scan
2014-03-06 13:05:25.9538 ? Scanning SQLSERVER10 on IP address 172.19.1.110 [Machine 1 of 1]
2014-03-06 13:05:26.5124 $ [172.19.1.110] Gathering computer system information
2014-03-06 13:05:26.6345 $ [172.19.1.110] Gathering computer system product information
2014-03-06 13:05:26.7351 $ [172.19.1.110] Gathering OS information
2014-03-06 13:05:26.7829 $ [172.19.1.110] Gathering time zone
2014-03-06 13:05:26.8269 $ [172.19.1.110] Gathering pagefile information
2014-03-06 13:05:26.9060 $ [172.19.1.110] Gathering network adapter configuration
2014-03-06 13:05:27.1843 $ [172.19.1.110] Gathering information about physical memory
2014-03-06 13:05:27.3737 $ [172.19.1.110] Gathering processor information
2014-03-06 13:05:29.3895 $ [172.19.1.110] Gathering system enclosure information
2014-03-06 13:05:29.4402 $ [172.19.1.110] Gathering CD-ROM Information
2014-03-06 13:05:29.5369 $ [172.19.1.110] Gathering disk information
2014-03-06 13:05:31.5985 $ [172.19.1.110] Gathering BIOS information
2014-03-06 13:05:31.6444 $ [172.19.1.110] Gathering local groups and group members
2014-03-06 13:05:32.7636 $ [172.19.1.110] Gathering local users
2014-03-06 13:05:33.2275 $ [172.19.1.110] Gathering information about logged on users
2014-03-06 13:05:33.6894 $ [172.19.1.110] Gathering IPv4 Route information
2014-03-06 13:05:33.9394 $ [172.19.1.110] Gathering event log settings
2014-03-06 13:05:34.0732 $ [172.19.1.110] Gathering printer information
2014-03-06 13:05:34.1445 $ [172.19.1.110] Gathering process information
2014-03-06 13:05:36.2286 $ [172.19.1.110] Gathering registry size information
2014-03-06 13:05:36.2735 $ [172.19.1.110] Gathering information about services
2014-03-06 13:05:37.6906 $ [172.19.1.110] Gathering information about shares
2014-03-06 13:05:37.7824 $ [172.19.1.110] Gathering Sound Device information
2014-03-06 13:05:37.8742 $ [172.19.1.110] Gathering TapeDrive information
2014-03-06 13:05:37.9523 $ [172.19.1.110] Gathering Video Controller information
2014-03-06 13:05:38.0753 $ [172.19.1.110] Gathering Startup Commands information
2014-03-06 13:05:38.5011 $ [172.19.1.110] Gathering application information from WMI
2014-03-06 13:05:38.6056 + [172.19.1.110] Unable to gather application information from WMI: Check that Win32_Product class is installed or Windows Installer Applications will not appear
2014-03-06 13:05:38.6164 + [172.19.1.110] You can add it with Add/Remove Windows Components -> Management and Monitoring -> WMI Windows Installer Provider
2014-03-06 13:05:38.6349 $ [172.19.1.110] Gathering application information from registry
2014-03-06 13:05:49.8443 $ [172.19.1.110] Gathering information about patches from WMI
2014-03-06 13:05:54.5291 $ [172.19.1.110] Gathering information about patches from registry
2014-03-06 13:05:58.4501 ? Scanned SQLSERVER10 at IP address 172.19.1.110 with 0 errors
2014-03-06 13:05:58.7353 ? Machine scan complete (Success: 1; Failure: 0)
2014-03-06 13:05:58.7539 ? Writing Inventory to disk
2014-03-06 13:05:58.7568 + No machines found!
2014-03-06 13:05:58.7607 ? End Script: C:\data-docs\sql-inven\Get-SqlServerInventoryToClixml.ps1