Failed to scan error message

Jul 10, 2013 at 5:43 AM

on Win7, Sql Server - doing a local test before trying on the network servers.

The scan process doesn't appear to be working on my machine. I have a local copy of Sql Server 2012 (I have sysadmin) and a copy of Sql Express, and I'm getting the following error in the log:
2013-07-10 13:10:54.5635 ? Beginning scan of 2 instance(s)
2013-07-10 13:10:54.6415 ? Gathering information from ASSET-101084.F.Q.N\SQLEXPRESS at [Instance 1 of 2]
2013-07-10 13:10:54.6495 ? Gathering information from ASSET-101084.F.Q.N at [Instance 2 of 2]
2013-07-10 13:11:09.7915 ! Failed to scan ASSET-101084.F.Q.N\SQLEXPRESS -  3 errors
2013-07-10 13:11:09.7975 ! Failed to scan ASSET-101084.F.Q.N -  3 errors
2013-07-10 13:11:10.0615 ? Instance scan complete (Success: 0; Errors: 2)
I am starting the process with the following:
.\Get-SqlServerInventoryToClixml.ps1 -ComputerName ASSET-101084 -IncludeDatabaseObjectInformation -IncludeDatabaseObjectPermissions -LoggingPreference debug -DirectoryPath .\Log
I have Admin access on my machine, and tried both with a normal Powershell session and an administrator Powershell session.

What am I doing wrong?

Jul 10, 2013 at 9:41 PM
Grab the beta version that's currently available in the downloads section ( There are some issues with scanning SQL Express instances in the current version that are fixed in the beta.

Thanks for trying out SQL Power Doc!

Jul 11, 2013 at 9:45 AM
Hi Kendal

I tried, but came up with the same error:

2013-07-11 17:42:30.4701 ? Gathering information from ASSET-101084.F.Q.D.N\SQLEXPRESS [Instance 1 of 2]
2013-07-11 17:42:30.4761 ? Gathering information from ASSET-101084.F.Q.D.N [Instance 2 of 2]
2013-07-11 17:42:30.6051 ! An unrecoverable error was encountered while attempting to retrieve information from ASSET-101084.F.Q.D.N\SQLEXPRESS
2013-07-11 17:42:30.8701 ! An unrecoverable error was encountered while attempting to retrieve information from ASSET-101084.F.Q.D.N
2013-07-11 17:42:31.1341 ? Instance scan complete (Success: 0; Failure: 2)

any further ideas?

Jul 11, 2013 at 9:29 PM
Are you using the Verbose logging level? That should give a clearer idea of what errors are going on.

You can also try running this code snippet in a PowerShell ISE window (make sure to change the instance name):
Import-Module -Name SqlServerDatabaseEngineInformation
Get-SqlServerDatabaseEngineInformation -InstanceName 'ASSET-101084.F.Q.D.N'
Remove-Module -Name SqlServerDatabaseEngineInformation
And then copy and paste the error here (after sanitizing the names in the output, of course).